PocketWizard Major ControlTL Firmware Update

The new ControlTL firmware (version details below) provides compatibility for several new Canon and Nikon cameras, greatly improves the performance of PocketWizard’s exclusive HyperSync feature and resolves bugs in previous versions. It is available now as a free download using the PocketWizard Utility and it is strongly recommended that all current owners of the MiniTT1, FlexTT5, PowerST4 and PowerMC2 update all their radios to the latest firmware for best performance.

The new firmware includes complete compatibility for the Nikon D600 and D3200 cameras and manual power control compatibility for the Canon EOS 6D, EOS-1D X and EOS Rebel T4i cameras.

In addition to the new camera compatibility, this new firmware version offers significantly improved HyperSync flash performance. This exclusive feature offers photographers the ability to use studio flash well beyond their camera’s normal x-sync speed, for greatly expanded creative control.

PocketWizard Utility version 1.54 or newer is required before installing these updates. For more information on the latest firmware versions and how to update PocketWizard products via USB connection visit the Pocket Wizard site.

The latest firmware versions are:

• 6.400 for the MiniTT1 and FlexTT5 for Canon
• 3.400 for the MiniTT1 and FlexTT5 for Nikon
• 5.400 for the PowerST4
• 2.400 for the PowerMC2
• 1.200 for the Plus III
• 7.51 for the MultiMAX


Other Articles


Leave a Reply

Your email address will not be published. Required fields are marked *


4 − three =

You may use these HTML tags and attributes: <a href="" title=""> <abbr title=""> <acronym title=""> <b> <blockquote cite=""> <cite> <code> <del datetime=""> <em> <i> <q cite=""> <strike> <strong>